Peer testing notes / findings / suggestion etc

Home Forums Vectorblade beta test Peer testing notes / findings / suggestion etc

Viewing 15 posts - 61 through 75 (of 78 total)
  • Author
  • #3186

    Chris i dont know any hardware experts unfortunately

    hmm, do you think arcade jason could help? i think he is a very busy person though, but you could bribe him with something perhaps πŸ™‚


    And now for something completely different:

    Got to level 25 yesterday πŸ™‚

    I was playing beta 11. Here are a a few minor things I noticed.

    Some of the triple pointed mines of the Mine Storm part showed what looked like the infamous vector gaps that appear when using scale factors different than (n*7 – 1). This is in no way a big deal, and I am only mentioning this because I know that you are a perfectionist. I can only guess that the original vector lists of the Mine Storm rom are used here, so there is propbaly no other way of having these mines displayed in exactly those sizes?

    Also, twice while getting killed during the Mine Storm part I had the impression that the collision detection might be a bit too strict. It really looked like there would definitely be enough space to squeeze through between some mines, but my ship exploded anyway. In other words, it really did not look like the ship would even be remotely touching anything. I will pay more attention to this in future runs and see if I can reproduce this or narrow it down to a certain situation or to a certain type of mine.

    And I probably need some help in understanding the “minor havoc” interlude. Either the graphics are partly wrong, or I am not getting an important part here. There is a circle drawn partly around Vec T. Rex, and I do not get its meaning. Also it looks like Vec T. Rex is sometimes running through air (space? vacuum?) and sometimes standing on or bouncing off invisible ground or obstacles. The directions are free, yet he cannot move there. Or he is standing on no ground and yet not falling down. It looks like the tile map does not match the displayed tiles? I still always get a “mission succeded”, but I have to admit that I don’t know why it succeded πŸ˜‰

    Level 25: the first time I saw the queen, I had what I thought of as quite some good fire power, but she killed my instantly, as I was standing right in the middle of the screen. I still had 5 lives left then, but my weapons reduced to only a one-shot at rate 5 or 6 at a not-too-fast speed. It was easy to figure out how to avoid the queen, but I tried for about 10(?) minutes, shooting until my fingers hurt. There was no way to get shots through all those enemies to the queen. At some point I just gave up and concluded that there is no way to beat this level with the given configuration of my ship. Is this true? Are there levels that cannot be beat unless you have reached at least a certain configuration? That would be ok, but it is rather unfortunate, if you reach such a level with an appropriate configuration, then get killed, and now your configuration is reduced to a point, where success is not possible anymore (no way to power up your configuration again). And I am talking about “not possible”, not about “very hard” or “unlikely” or “improbable”, but “100% impossible”. That would mean whatever lives you have left at that point, they are wasted. Well, I will certainly try again tonight πŸ˜‰



    I got your VIA today – and I am still trying to figure it out.
    Until I have more to say, I’ll keep quiet – for now.

    The Major Havoc part is the one part that is not finished in any way. It will either feature some levels at the end of
    the minestorm where you can “collect” something good – or completely vanish from the game, if time and space runs out…
    Don’t worry about that just now.

    The Queen. Yea, you can certainly get to her and not be able to kill her.
    But honestly – it doesn’t need a great shot, mostly persistence.

    You CAN kill her with a one shot, some medium rate and some medium amount of bullets.
    You must get shots thru the protectors, only shots that it the Queen itself count. She can also only be hit between her mandibles…

    If I happen to come to her with a one shot (for whatever reason) – yes it takes a bit of time…

    I have to test the colision detection again in Minestorn than. But you are right, the vectorlists and the printing is done all BIOS. And since the size is “random” (pure random) – there are sizes where gaps happen. That is Vectrex – here goes my perfectionism….


    just wanted to comment on the subjects Peer mentioned:

    minestorm collision detection: i have thought that myself too sometimes, i thought i might be able to sneak through a gap but ended up dying even though it felt like i might have fit through ok, Chris perhaps you could just tweak it a bit (if that’s not a major headache to do of course)

    the first boss (queen):
    i think i have mentioned the same concern to Chris in the past, that if you have weak single shot there it is very difficult and can be quite painful on the fingers trying to do get bullets past the small enemies,
    (personally speaking though i dont tend to get there with weak weapons anymore so i guess i just dont worry about that now) .. anyway perhaps the other testers will bring this up again


    Excellent analysis and write-up, thanks!

    I will run the WeirdTest binary on all my consoles, just out of curiosity. I will also ask one of my former students, who has a Vectrex of his own, to test on his machine.


    Have not reached the student yet, but all my consoles show no weird behaviour (now).


    Just tried beta 18 for the first time. I used a no-buzz console. Here are some minor remarks/suggestions:

    – buzz/no buzz selection: text “Button 4 to confirm” is not horizontally centered

    – the calibration sub menus all use a different brithness, if your console’s brightness (poti on the back) is set too low at the beginning, some of the entries cannot be seen, so maybe an initial hint like “you will probably need to adjust your console brightness” would be good, or do some “console brightness setup” like in the TestRev card, “turn up console brightness until you see all these lines”, something like that.

    – help text of the first boss calibration step, missing letter: “… align the(m) as good as possible”


    Can’t I sneak anything by you guys?

    Will fix all of the above… πŸ˜‰


    Here is a question/idea:

    Have you ever considered the possibility that parts of your current equipment (ship configuration) can also be sold in the shop? Trade them in for money, then use that money to buy other things? That would add another nice tactial element. Of course the shop owner is a business alien, buying things back only at a lower price than at what they were initially sold πŸ˜‰


    No haven’t sounds cool -> marked for “Vectorblade Mark II”.

    THIS Vectorblade has a feature freeze :-).

    Gees – don’t you guys find enough bugs anymore? Now you want to add something new?



    Well, it is just that at some point while playing Vectorblade today I would have sold a life to get money to buy more fire power πŸ˜‰

    Do you know Xenon II – Megablast (mid eighties, by the Bitmap Brothers, played it on the Atari ST)? That one has a similar style. Get add-ons and money while shooting, then stop by at the shop, trade in what ever you are willing to give away, and buy more stuff.

    Feature freeze is perfectly fine πŸ™‚

    But while we’re at it: What about some R-Type like power-shot feature for “Vectorblade Mark II”?

    Hold fire-button pressed, shot fires only once the button is released again, and the longer you have pressed, the more powerful the shot. So basically you go into evasive manouvering for a while, and then BAM! I always liked this about R-Type. Even if you have nothing else, with this you still have a chance against the bigger aliens. Well, if you are good at manouvering…


    Gees – don’t you guys find enough bugs anymore? Now you want to add something new?

    We testers are inventive and have cool ideas and day dreams – haven’t we? And sure enough we want to find out what it takes to drive you crazy. πŸ˜‰


    One more minor observation / thought regarding the scoopies:

    While transitioning from one level to the next (Level n+1 appears on the screen), the ship is drawn without any additional equipment. In my opinion, this looks a little confusing when having scoopies at your side. First, the scoopies are there while the action is going on, then you finish the level, now the scoopies disappear while the next level is announced, then they are there again. I might look better if the scoopies just stay at your side while the next level message comes up.


    Well – yes.
    This has technical reasons. During “intermissions” (even if it is only the text, but especially during warp/minestorm) the memory management differs from “in game”.
    I only remember in a save location that I have scoopies, and which race… all other information is lost and not available.
    The enemy “structures” are rebuilt after the intermission.

    So actually from a technical point of view there are no scoopies during these times.

    And you also know what? The original Warblade does exactly the same (I don’t know if with the same background though).

    ROFL – it’s nice to say “no”… Keep trying you might get me on the right foot and I’ll say yes to something again…

Viewing 15 posts - 61 through 75 (of 78 total)
  • The forum ‘Vectorblade beta test’ is closed to new topics and replies.